Utilizzare la Google Nik Collection

 con Paint.net e GIMP

© Copyright Programmifree.com.  E' vietata la copia anche parziale senza il consenso scritto dell'autore.

 

 

giuda inserita: Luglio 2016

La Google Nik Collection è una collezione di 7 filtri di altissima qualità (per ridurre il rumore, correggere il colore, bianco e nero, controllare la tonalità, HDR, ecc.).
Sarebbe rivolta soprattutto agli utenti di Adobe PhotoShop, ma vedremo adesso come utilizzarla con Paint.net e GIMP.

PREMESSA: Si possono utilizzare i filtri della Google Nik Collection anche senza altri programmi. Con 4 di essi è sufficiente fare un doppio clic sull'exe e utilizzarli come un normale software.
Con gli altri 3 (Dfine, Sharpener Pro, Viveza) manca invece il menu File, dal quale si possono caricare/salvare le immagini. Per ovviare alla cosa, è possibile trascinare l'immagine da modificare direttamente sull'icona dell'eseguibile.
In questo modo l'immagine si aprirà e potremo modificarla e salvarla (importante: mancando il menu File→Salva immagine con nome, quando cliccheremo su Salva l'immagine di partenza verrà sovrascritta, dunque è opportuno lavorare solo con delle copie).

Utilizzare la Google Nik Collection con Paint.net

  1. Installiamo Google Nik Collection e Paint.net.

  2. Scarichiamo 8bf plugin filter (è un plugin che permette di caricare i filtri di Adobe PhotoShop in Paint.net)

  3. Scompattiamo questo plugin e copiamo i file PSFilterPdn.dll e PSFilterShim.exe nella cartella Effects di Paint.net (in genere C:/Programmi/paint.net/Effects/ )

  4. Avviamo Paint.net e clicchiamo Effetti→8bf Filters→Search Directories→Add.

  5. Andiamo a selezionare la cartella dove è installata la Google Nik Collection (in genere C:Programmi/Google/Nik Collection) e clicchiamo OK. Aggiunta la cartella della Nik Collection, clicchiamo ancora OK.

  6. D'ora in poi, per utilizzare la Nik Collection in Paint.net, basterà caricare la nostra immagine da modifica, poi Effetti→8bf Filter, clicchiamo sul '+' per espandere la collezione, scegliamo un filtro e clicchiamo Run Filter.

    Quando abbiamo finito l'elaborazione, clicchiamo OK (prima sulla finestra del filtro e poi su quella di 8bf) per avere la nostra immagine elaborata in Paint.net

  7. Al momento funzionano tutti i filtri, ad eccezione di Viveza (che per qualche ragione, mentre lo si utilizza in Paint.net, va in crash).

  8. E' anche presente un video che illustra come fare

     

----------------------------------------------------------------

Utilizzare la Google Nik Collection con GIMP

  1. Installiamo Google Nik Collection e GIMP.

  2. Scarichiamo il plugin ShellOut e scompattiamo il file al suo interno (Shellout.py).

  3. Utilizziamo un editore di testo (SynWrite, Notepad++, NoteTab Light, ecc.) per caricare Shellout.py e aggiungere le righe qui sotto dopo  programlist = [  (basta fare copia e incolla con attenzione).
     

  4. ["DFine 2", "\"C:\\Programmi\\Google\\Nik Collection\\Dfine 2\\Dfine 2 (64-Bit)\\Dfine2.exe\"", "png"],
    ["Sharpener Pro 3", "\"C:\\Programmi\\Google\\Nik Collection\\Sharpener Pro 3\\Sharpener Pro 3 (64-Bit)\\SHP3OS.exe\"", "png"],
    ["Viveza 2", "\"C:\\Programmi\\Google\\Nik Collection\\Viveza 2\\Viveza 2 (64-Bit)\\Viveza 2.exe\"", "png"],
    ["Color Efex Pro 4", "\"C:\\Programmi\\Google\\Nik Collection\\Color Efex Pro 4\\Color Efex Pro 4 (64-Bit)\\Color Efex Pro 4.exe\"", "jpg"],
    ["Analog Efex Pro 2", "\"C:\\Programmi\\Google\\Nik Collection\\Analog Efex Pro 2\\Analog Efex Pro 2 (64-Bit)\\Analog Efex Pro 2.exe\"", "jpg"],
    ["HDR Efex Pro 2", "\"C:\\Programmi\\Google\\Nik Collection\\HDR Efex Pro 2\\HDR Efex Pro 2 (64-Bit)\\HDR Efex Pro 2.exe\"", "jpg"],
    ["Silver Efex Pro 2", "\"C:\\Programmi\\Google\\Nik Collection\\Silver Efex Pro 2\\Silver Efex Pro 2 (64-Bit)\\Silver Efex Pro 2.exe\"", "jpg"],

     

  5. [Facoltativo] Se non ne abbiamo bisogno, possiamo cancellare l'elenco di tutti gli altri programmi dal file Shellout.py dopo quelli che abbiamo appena incollato. Renderanno più immediata ed elegante la successiva selezione in GIMP.

  6. Salviamo il file Shellout.py appena modificato.

  7. Copiamo Shellout.py nella cartella dei plugin di GIMP (C:Programmi/Gimp 2/lib/gimp/2.0/plug-ins/ )

  8. Avviamo GIMP e carichiamo un'immagine da elaborare.

  9. Filtri→Shellout. Adesso possiamo selezionare il filtro della Nik Collection che vogliamo.

  10. Al momento con GIMP funzionano tutti i filtri, ad eccezione di HDR Efex Pro 2 (per qualche ragione, dopo che si è elaborata l'immagine con HDR, la stessa non viene più restituita a GIMP, ma viene ricaricata l'immagine originale).
     

  11. E' anche presente un video che illustra come fare